lpcware

Unable to install

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jul 4, 2016 by Gray Girling
Content originally posted in LPCWare by c0dehunter on Tue Sep 11 02:34:47 MST 2012
I am unable to install LPCXpresso (same goes for Red Suite) on 64bit Ubuntu 12.04. I have 32bit support libraries. I am a linux guy so I am pretty sure the configuration is alright as far as the OS is concerned.

If I try to double click the installation nothing happens.

If I run the installer from terminal, I get these (InstallJammer) error:
c0dehunter@mintBox ~/Downloads $ sudo ./Installer_LPCXpresso_4.2.3_255_Linux-x86 
[sudo] password for c0dehunter:

invalid command name "bind"
    while executing
"::unknown bind Text <Tab>"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 $next $args"
    (procedure "::obj::Unknown" line 3)
    invoked from within
"bind Text <Tab>"
    (procedure "::InstallJammer::InitializeGui" line 19)
    invoked from within
"::InstallJammer::InitializeGui "
    (procedure "::InstallJammer::InitInstall" line 68)
    invoked from within
"::InstallJammer::InitInstall"
    (file "/installkitvfs/main.tcl" line 36228)


If I try to run the installer from terminal, but with "--mode console" flag:
This will install LPCXpresso on your computer.  Continue? [n/Y] Y


Where do you want to install LPCXpresso? [/usr/local/lpcxpresso_4.2.3_255]

Installing LPCXpresso...
Error in action ExecuteAction

Error in action InstallSelectedFiles

couldn't execute "/tmp/ijtmp_5A0F6295-D9B0-C0B3-49BF-0954047E4DE0/installkit": permission denied
    while executing
"open $cmd"
    (procedure "::InstallJammer::actions::InstallSelectedFiles" line 131)
    invoked from within
"::InstallJammer::actions::$component $self"
    while executing
"::obj::classes::Action::Method_execute ::obj::classes::Action Action1"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 [list $command $classns $obj {*}[lrange $args 2 end]]"
    (procedure "::obj::Unknown" line 11)
    invoked from within
"$obj execute"
    (procedure "::InstallJammer::ExecuteActions" line 85)
    invoked from within
"::InstallJammer::ExecuteActions $action -parent $id -conditions $eval"
    (procedure "::InstallJammer::actions::ExecuteAction" line 35)
    invoked from within
"::InstallJammer::actions::$component $self"
    while executing
"::obj::classes::Action::Method_execute ::obj::classes::Action DF5A8644-E41D-4C27-B8B5-26C5E8BD7102"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 [list $command $classns $obj {*}[lrange $args 2 end]]"
    (procedure "::obj::Unknown" line 11)
    invoked from within
"$obj execute"
    (procedure "::InstallJammer::ExecuteActions" line 85)
    invoked from within
"::InstallJammer::ExecuteActions Console"
    (procedure "::InstallJammer::InstallMain" line 11)
    invoked from within
"::InstallJammer::InstallMain"
    (procedure "ThemeMain" line 2)
    invoked from within
"ThemeMain "
    invoked from within
"if {![info exists ::InstallJammer]} { ThemeMain }"
    (file "/installkitvfs/main.tcl" line 36318)


I tried reversing tcl from ver. 8.5 to 8.4 - it didn't help. Also, I tried running all of the above commands as sudo and even from su. Also chmodded and chowned, nothing helped.

Does anyone have any other suggestion? If not, who should I contact further about this? I was forced to temporarily reassign 7 developers to another project branch due to this error.

Outcomes