lpcware

Any access to CLK_USB branch registers causes debugger to crash

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by rlund on Thu Jul 24 11:35:36 MST 2014
We have triple checked the manual and other registers (such as the base clock), and everything seems to be in working order.

Using an LPC Link 2 debugger board
Using the free code limited version of LPC Xpresso
Tried using a KEIL MCB1800 (LPC chip 1857) demo board
Also tried using an 1837 xplorer board (with the same results)
Tried with multiple different "base" projects (a clean one, a custom one we were working on, even one of the LPC open projects)

Any reads from memory location 0x4005 1800, 0x4005 1804, 0x4005 900, or 0x4005 904 cause the debugger to crash, and require a reset of the target board.
These are the config and status registers for the USB branch clocks, within the CCU1 register.

Any help or pointers on common places to look would be very much appreciated.  Thank you in advance!

Outcomes