lpcware

Can't flash LPC1227 after Windows 10 upgrade from Windows 7

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by tdl on Sat Dec 12 12:21:12 MST 2015
I have a device with an LPC1227.  Since upgrading to Windows 10, I cannot flash this device.  It worked fine before the upgrade. Now it always gives the error:

Flash driver "EraseSector" timeout (3000 ms)  PC: 1FFF1536
  Flash driver "EraseSector" timeout (3000 ms)  PC: 1FFF1536
  15: Target error from Commit Flash write: Ec: Flash driver "EraseSector" timeout (3000 ms)  PC: 1FFF1536

I have tried upgrading to lpcxpresso 7.9 and 8.0. Same problem.
I removed the USB driver and reinstalled lpcxpresso 8.0 and get the same error.

To prove that the LPC1227 was fine, I pulled out an old machine that has Windows 7 and Lpcxpresso 6.x and it can flash the device with no problem. Taking it back to the Windows 10 machine still gives the error above. 

Is this a driver issue?  Can someone give me any ideas of what else to try? 

Thanks!

Outcomes