lpcware

Cannot debug or flash the LPC1769 stick

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 18, 2016 by lpcware
Content originally posted in LPCWare by xjx on Wed Mar 16 15:29:32 MST 2016
Hello,

Currently I can not flash new programs to the LPC1769.

The part was working good using LPC IDE version 7.8.0.

After I tried to debug using another computer with IDE version 7.3, the problems started.

Now I can not flash or debug anymore.

This is the message I get:

[color=#390]PCXpresso Debug Driver v7.8 (May 28 2015 02:56:31 - crt_emu_cm3_nxp build 181)
Emu(0): Conn&Reset. CpuID: 410FC230. Info: HID64HS12
Debug protocol: SWD Frequency 3000 KHz. RTCK: Disabled. Vector catch: Disabled.
loaded v.2 On-chip Flash Memory LPC175x_6x_512.cfx
image 'LPC175x_6x (512K) May 21 2015 09:32:27'
NXP: LPC1769  Part ID: 0x00000000
Connected: was_reset=false. was_stopped=true
LPCXpresso Free License - Download limit is 256K
V.2 flash driver never became ready (after 1505 ms) - status still 0x0
SP:     10000600
LR:     FFFFFFF9
PC:     00000028
xPSR:   00000003
Flash Driver V.2 startup failed - rc Ef(9). Flash operation aborted.
driver "Terminate" timeout (500 ms)  PC: 00000028
Target error from Commit Flash write: Ef(9). Flash operation aborted
.[/color]



To fix the problem, I tried the following, with no success:
"Board recovery using the ISP pin
If the board's FLASH can no longer be programmed, the image in FLASH may be corrupt. To recover the board, the board must be reset with the ISP (P2.10) pin held low. To do this, attach a jumper between pin J6-51 (P2.10) and J6-1 (GND) and reset the board. "


please help!!!

Outcomes