lpcware

Failed on connect: Ee(XX). Could not connect to core.

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 18, 2016 by lpcware
Content originally posted in LPCWare by kurtm on Mon Mar 14 09:26:10 MST 2016
I have problems to program my LPC824 parts.

I have two programmers, one LPC-Link 2 and one LPC82x Xpresso V2 mbed.
I have recently updated to latest version of LPCXpresso (8.1.2)

When trying to program flash, I will get error message: Failed on connect: Ee(36). Could not connect to core.

I have modified the LPC82x Xpresso V2 mbed card so that I can connect an external card, but with jumpers so that I still can program the CPU on the board. This has worked OK earlier with several boards and an earlier version of LPCXpresso (7.something). I can still program the CPU on the board, but not external cards. I have tried to program 3 external cards with both my programmers, but I always get the same error message.

I see some brief activity on SWDIO and SWCLK on the chip when programming. I have tried with 47K pullup on SWDIO and 47K pulldown on SWCLK (as fig 11 page 30 in datasheet) and also without resistors on these pins, but there is no difference.

Could someone clarify wat the error code Ee(36) means? It might be helpful to resolve the problem. I think it would be nice with an explanation of all error codes.

Kurt Mirdell

When testing some more, I managed to connect one single time. Flashing was made without any problem. Image loaded was periph blinky. It works and toggles one pin. However, after that it was impossible to do connect again. Same error message. I suspect that there is some connecton problem and shorted the connection length from 30 cm to 8 cm, but still no connect.

Outcomes