lpcware

LPC5400 processor fails to halt

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by mirfan on Fri Nov 14 00:08:07 MST 2014
Hi,

I am using LPC5400 Xpresso V2 board. I started porting an OS kernel on this processor using the on-chip 96KB SRAM for both code and data. Everything worked fine until I shifted from on-chip SRAM to on-chip FLASH for my code. I flashed the code using LPCXpresso v7.4.1_beta1 [Build 234] [2014-09-25] IDE using the CMSIS-DAP interface. The code was flashed successfully by the debugger. However, since then Im unable to reconnect to the target via either the CMSIS_DAP or JLINK SWD interface. With both these interfaces I get the error that the "Processor can't be halted".

The code that I flashed may not have been a working code, but it should not have left me with a processor that I cannot connect to. I tried flashing the target again with FlashMagic, but FlashMagic too fails to connect to the target. It throws the error: "Operation Failed. Failed to autobaud - step 1. See http://www.flashmagictool.com/autobaud.html".

Is there anything I can try to get the processor out of this state? May be some way of re-flashing the target, or erasing the entire flash might help.

Outcomes