lpcware

LPC2214 JTAG Issue / Thoughts?

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by birdbren on Tue Mar 25 11:11:46 MST 2014
Have an issue as outlined below, is there anything that could cause the JTAG connection to be lost with this code sequence?  The only thing I can think of is the CRP Register (Flash location 0x000001FC) but that doesn't seem to be happening.

Any thoughts?

I have a question about the LPC2214, and the LPC2294. We are using IAR's Embedded Workbench. I copied a working project to a new directory changed some settings, and inadvertently included the following under the debugger options.

$PROJ_DIR$\config\ram.mac

This file contains the following

execUserPreload()
{ // __writeMemory32(Value,  Location, Type);
  __writeMemory32(0x20003CE3, 0xFFE00000, "Memory");
  __writeMemory32(0x20003CE3, 0xFFE00004, "Memory");
  __writeMemory32(0x20003CE3, 0xFFE00008, "Memory");
  __writeMemory32(0x20003CE3, 0xFFE0000C, "Memory");
  __writeMemory32(0x0E6149E4, 0xE002C014, "Memory");  // PINSEL2: CS0, CS1, CS2, OE, WE, BLS0..3, D0..31, A2..23, JTAG
}

So it appears to me that by including this file which changes memory location  0xE002C014 with the value 0x0E6149E4 I have adversely affected the JTAG pins. This is what IAR support is telling me that this file would do. Is it possible that I may have moved the JTAG pins to a different port (PORT 2?). Currently I can not program the chip, and I tried it on two different boards. Both boards worked fine until I tried to download my project. All that I did was to change the program settings in IAR and tried to download. Is there a way to reset the chip? By the way one of the boards is an Olimex LPC-H22xx. The project was copied from a working Blinky project from Olimex.

Outcomes