lpcware

UART-ISP not working on LPC1110?

Discussion created by lpcware Employee on Jun 15, 2016
Content originally posted in LPCWare by MarcVonWindscooting on Fri Oct 18 02:36:43 MST 2013
Hi,

I already posted something similar in the LPC800 forum, but that's is obviously the wrong place.

I tried to flash a LPC1110FD20 (1kiB RAM) using my program mxli, the program lpcprog (another open source tool) and lpc21isp (yet another open source tool) on a Linux machine using a PL2303 (clone, MXT2303) USB-to-Serial converter. All of the programs failed and the problem is, that the checksum provided for the transfers to RAM are all rejected by the bootloader. The programs work fine for LPC1114 (with 4kiB RAM) to provide some evidence they calculate the checksum correctly.

I tried different transfer RAM locations 0x00,  0x40, 0x300 but no success.

My question is: has anybody successfully programmed LPC1110FD20, maybe even with one of the tools mentioned?
Any hint as to why this can fail?

[color=#f03]EDIT: Update:[/color]
I solved it.
I found that FlashMagic uses address 0x200 and that works fine. This is in documented in UM10398 12.1 (Aug 2013). The 2012 manual documents this as 'used by the ISP' handler, what is obviously wrong for the LPC1110.

For mxli the option to flash LPC1110  is: -R 0x200,0x100 besides limiting baudrate to 38400 for example.

Outcomes