lpcware

LPC11C14 CAN onchip only in debug mode

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 16, 2016 by lpcware
Content originally posted in LPCWare by sa.ha on Thu Oct 24 12:07:16 MST 2013
Hello, I have tried the example project "can_onchip" in LPCXpresso with the LPCXpresso LPC11C24 Development Board (using only the LPC Link, no connections to the LPC11C24 target board). I'm using my own LPC11C14 board which is connected to the LPC Link via a SWD-Cable.  I have changed the CAN bus baudrate to 500k. The problem is that the programm runs only in debug mode with connected LPC Link. I can send and receive data but when I disconnect the LPC Link from my LPC11C14 board and power off, then power on my board the CAN connection does not work. I can't send or receive CAN messages. All other programm parts are working. (toggle Pin every 10ms, which I can see on the scope)
Then I tried the "can" example project and all works fine (debug and standalone mode).
I have read something about semihosting. Could this be the problem? How can I disable it? I searched the forums but couldn't find any solution. I hope someone can help me.

Outcomes