lpcware

LPC11U67 - ISP Serial

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by mbehlau on Wed Sep 17 09:05:17 MST 2014
Hi,

i wan't to flash my LPC11U67 about the serial interface. I tested the connection with the flash magic tool with a windows based PC. This is working fine.

Next, i want to flash the device from my linux pc. Unfortunately there is no application, which is supporting the LPC11U67. I tried to add the support, but this won't work.

I tried the mxli software:

sudo ./mxli -N LPC11U67 -F4kix24,32kix1 -B1024,4096 -A0x00000000 -M16ki@0x10000000,2ki@0x20000000 -I0xA0000BC88 -S8@7 -R0x200@0x10000000 -g lpc11U67.hex


If i don't use sudo, i get a memory access error. The process is very fast, but the device isn't programmed. I tested a lpc1769, which is supported directly, and get the same result. (memory access error, and the device isn't programmed).

Then i tested the lpctools. I added the following entry to the "lpctools_parts.def"-file.

0x0000BC88, LPC11U67,           0x00000000, 0x20000, 8,    0x04,    0x10000000, 0x4000, 0x800, 0x800,   1


My command:

./lpcprog -d /dev/ttyUSB0 -c flash ../lpc21isp_197/lpc11U67.hex


Application Output:


Part ID 0x0000bc88 found on line 24
Flash now all blank.
Checksum check OK
Flash size : 131072, trying to flash 11 blocks of 1024 bytes : 11264
Writing started, 11 blocks of 1024 bytes ...
Received error code '9': SECTOR_NOT_PREPARED_FOR_WRITE_OPERATION
Unable to copy data to flash for block 4 (block size: 1024)


Then I tried to add the support to the lpc21isp application in different files. But the output is only:

lpc21isp version 1.97
File lpc11U67.hex:
        loaded...
        converted to binary format...
        image size : 3912
Image size : 3912
Synchronizing (ESC to abort)..... OK
Read bootcode version: 1
13
Read part ID: LPC11U67, 128 kiB FLASH / 20 kiB SRAM (0x0000BC88)
Will start programming at Sector 1 if possible, and conclude with Sector 0 to ensure that checksum is written last.
Erasing sector 0 first, to invalidate checksum. OK
Sector 0: ..Wrong answer on Prepare-Command (2) (Sector 0)
ErrorString:


Is there another tool, which supported the device directly? Or could somebody check my configs?

Thanks in Adance,

Marcel

Outcomes