lpcware

Can't Debug LPC4357-M4

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by TahaSN on Thu Apr 16 14:11:45 MST 2015
Hi,

We populated a custom board which includes LPC4357 and when I tried to program the chip using IAR debug, it stopped on the main function as usual but then when I ran the code it gave me an error that it failed to get the CPU status and closed the debugger. I tried the same code on another custom board and it works fine. We thought that it went into some code protection mode, so I tried to boot into ISP mode by putting P2_7, P1_1, P1_2, P2_8 and P2_9 low in order to boot from USART0 mode. But I still didnt get anything back from there.

I also tried to use Flash Magic software (I haven't used it before) in order to get some kind of access but I got nothing. I did realise that when the uC is in USART0 mode, I am able to program the device but it never runs the code. Do you guys have any idea what can be wrong because I am currently out of ideas. Please let me know if you need some other information in order to help me out. I will try my best to provide the information as quickly as I can.

Thanks
Taha

Outcomes