lpcware

LPCOpen v2.02 sdmmc_speed.c hard faults?

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by jonper on Thu Nov 21 11:49:23 MST 2013
When I run lpcopen v2.02 with and unmodified misc\sdmmc_speed example, it freezes after the message "Taking back up of card." Halting the debugger shows the PC stuck in the hard fault handler. Resetting and single stepping point to something failing in the first Chip_SDMMC_ReadBlocks call.

If I revert to lpcopen 1.03 and run the older but near-twin misc\app_sdmmc_meas with the v1.03 chip/ip libraries, the same hardware gives a successful full run.

If I run the alternate v2.02 periph_sdmmc\sdmmc example using the same hardware and the same shared chip code base, everything works fine.

I've tried this with LPCXpresso_6.1.0_164, Keil uVision V4.72.10.0, and IAR 6.70.1 compilers, testing on both the MBC4357 eval board with MicroSD cards, and on our custom LPC4357 boards with various SD cards. In all those combinations of hardware and software, v2.02's misc\sdmmc_speed example hard faults while v1.03's misc\app_sdmmc_meas works.

Initial debugging attempts and code comparisons make me think its likely a simple translation error, but I just can't see it. Anyone willing to take a look or offer suggestions?

Outcomes