lpcware

LPC4350 IAR and J-Trace Cortex M

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by gregd on Tue Jul 31 20:03:47 MST 2012
I am using the Hitex LPC4350 Rev A4 evaluation board along with the Segger J-Trace Cortex M with the IAR EWARM v6.40.1.3812. I am running J-Link DLL v4.50m and J-Trace Cortex-M Rev.3 firmware.

I have been using this setup for several months. At first everything seemed to work very reliably. As my project got larger, I have started having problems downloading the images to the board. I have tried two different Hitex boards with the same results. The same issue seems to occur with a standard J-Link ARM debugger as well. I am storing the program in the external NOR flash on the board when debugging and I have “verify download” enabled. I am using the latest version of the Hitex NOR flash program that came with the lpc43xx.git project (LPC43xx CMSIS driver library) from the sw.lpcware.com website. I have also tried the flash program included with IAR with the same results.

Basically, what seems to be occurring is that 99% of the time, the first download/debug attempt fails with the results shown in the attached file. The second attempt always works 99.9999% of the time with no errors. If you simply hit the debug tool bar button over and over without recompiling, it seems to be successful only every other time very repeatedly.

In the attached file, I have included the debug log and flash0.trace file, and IAR J-Link configuration dialog boxes for your review.

Anyone have any suggestions? This issue eventually starts to waste a lot of time.

Thanks,
Greg Dunn
304-542-4383

Original Attachment has been moved to: LPC4350%20Download%20Problems.zip

Outcomes