lpcware

problems building LPCOpen v.1.02 examples

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by bowerymarc on Wed Apr 10 15:43:41 MST 2013

I've downloaded LPCOpen v1.02, and lpcxpresso_5.1.2_2065, to try to do some SD Benchmarking using the Hitex Eva 4350 board.


I've imported the following projects into my workspace:


lpc18xx_43xx_lib_lpc_board


lpc43xx_hitex_eva_4350_board_lib


lpc43xx_hitex_eva_4350_board_lib_m0


lpc43xx_hitex_eva_4350_periph_sdmmc


On the first library (lpc_board) I selected the hitex_eva_4350 build target.  I'm able to build all 3 libraries with no errors.  But when I build the sdmmc project I get this:


<code>18:12:28 **** Incremental Build of configuration Debug for project lpc43xx_hitex_eva_4350_periph_sdmmc ****</code><code>make -j4 all </code><code>Building file: Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/rtc.c</code><code>Building file: Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/fs_mci.c</code><code>Invoking: MCU C Compiler</code><code>Invoking: MCU C Compiler</code><code>Building file: Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/applications/lpc18xx_43xx/examples/periph/periph_sdmmc/sdmmc.c</code><code>arm-none-eabi-gcc -D__REDLIB__ -DDEBUG -D__CODE_RED -DCORE_M4 -I"../../../../../../../software/CMSIS/CMSIS/Include" -I"../../../../../../../software/lpc_core/lpc_ip" -I"../../../../../../../software/filesystems/fatfs/src" -I"../../../../../../../software/filesystems/fatfslpc" -I"../../../../../examples/periph/periph_sdmmc" -I"../../../../../../../software/lpc_core/lpc_chip/chip_18xx_43xx" -I"../../../../../../../software/lpc_core/lpc_chip/chip_common" -I"../../../../../../../software/lpc_core/lpc_board/board_common" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350/hitex_eva_4350" -O0 -g3 -Wall -c -fmessage-length=0 -fno-builtin -ffunction-sections -fdata-sections -fsingle-precision-constant -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -mthumb -MMD -MP -MF"fatfs/rtc.d" -MT"fatfs/rtc.d" -o "fatfs/rtc.o" "Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/rtc.c"</code><code>arm-none-eabi-gcc -D__REDLIB__ -DDEBUG -D__CODE_RED -DCORE_M4 -I"../../../../../../../software/CMSIS/CMSIS/Include" -I"../../../../../../../software/lpc_core/lpc_ip" -I"../../../../../../../software/filesystems/fatfs/src" -I"../../../../../../../software/filesystems/fatfslpc" -I"../../../../../examples/periph/periph_sdmmc" -I"../../../../../../../software/lpc_core/lpc_chip/chip_18xx_43xx" -I"../../../../../../../software/lpc_core/lpc_chip/chip_common" -I"../../../../../../../software/lpc_core/lpc_board/board_common" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350/hitex_eva_4350" -O0 -g3 -Wall -c -fmessage-length=0 -fno-builtin -ffunction-sections -fdata-sections -fsingle-precision-constant -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -mthumb -MMD -MP -MF"fs_mci.d" -MT"fs_mci.d" -o "fs_mci.o" "Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/fs_mci.c"</code><code>Invoking: MCU C Compiler</code><code>arm-none-eabi-gcc -D__REDLIB__ -DDEBUG -D__CODE_RED -DCORE_M4 -I"../../../../../../../software/CMSIS/CMSIS/Include" -I"../../../../../../../software/lpc_core/lpc_ip" -I"../../../../../../../software/filesystems/fatfs/src" -I"../../../../../../../software/filesystems/fatfslpc" -I"../../../../../examples/periph/periph_sdmmc" -I"../../../../../../../software/lpc_core/lpc_chip/chip_18xx_43xx" -I"../../../../../../../software/lpc_core/lpc_chip/chip_common" -I"../../../../../../../software/lpc_core/lpc_board/board_common" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350" -I"../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350/hitex_eva_4350" -O0 -g3 -Wall -c -fmessage-length=0 -fno-builtin -ffunction-sections -fdata-sections -fsingle-precision-constant -mcpu=cortex-m4 -mfpu=fpv4-sp-d16 -mfloat-abi=softfp -mthumb -MMD -MP -MF"sdmmc.d" -MT"sdmmc.d" -o "sdmmc.o" "Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/applications/lpc18xx_43xx/examples/periph/periph_sdmmc/sdmmc.c"</code><code>In file included from Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/rtc.c:14:0:</code><code>../../../../../../../software/lpc_core/lpc_chip/chip_18xx_43xx/chip.h:32:24: fatal error: sys_config.h: No such file or directory</code><code>compilation terminated.</code><code>make: *** [fatfs/rtc.o] Error 1</code><code>make: *** Waiting for unfinished jobs....</code><code>In file included from ../../../../../examples/periph/periph_sdmmc/fsmci_cfg.h:43:0,</code><code>                 from Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/software/filesystems/fatfslpc/fs_mci.c:32:</code><code>../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350/board.h:35:38: fatal error: board_hitex_eva_18504350.h: No such file or directory</code><code>compilation terminated.</code><code>make: *** [fs_mci.o] Error 1</code><code>In file included from Y:/BEA/ioti/software/lpcSDBenchmarking/LPCOpen_v1.02/applications/lpc18xx_43xx/examples/periph/periph_sdmmc/sdmmc.c:33:0:</code><code>../../../../../../../software/lpc_core/lpc_board/boards_18xx_43xx/hitex_eva_18504350/board.h:35:38: fatal error: board_hitex_eva_18504350.h: No such file or directory</code><code>compilation terminated.</code><code>make: *** [sdmmc.o] Error 1</code><code>
</code><code>18:12:31 Build Finished (took 2s.437ms)</code>


I get the same errors when trying other projects (e.g. freertos_blinky)


what's really odd is, they compile OK with the OSX version of LPCXpresso, but not the windows one!  (I had to switch because the Keil ULINK2 apparently isn't supported in the OSX version, even though the device is a bog-stock USB HID as far as the OS is concerned and needs no drivers).


Anyone have a clue what's going on??

Outcomes