lpcware

LPC4357 can't debug anymore

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by pgeloso on Thu Jun 04 09:40:24 MST 2015
Hi,
I've an embedded artist LPC4357 board and a LPC-Link2 programmer.
Suddenly I can't access the debug mode anymore.
I have also a second kit of embedded artists LPC4357 board and link2 but the problem is not related to the hw. The lpc4357 has the demo code and has never been programmed before, but still I cannot access it.
(I connect the board to a USB3 port and Link2 to a USB2 port.)

The error message refers to an hw transfer fail, but I didn't change the hw set up before the fail..

Do you know how to face this issue?

I'm reporting the error message:
[Started server]
[Connected on port 3025]
redlink>
redlink>
redlink>
redlink>
redlink>
redlink>ProbeList
Index = 1
Manufacturer = NXP
Description = LPC-LINK2 REDLINK
VID = 21BD, PID=0006
Path = \\?\hid#vid_21bd&pid_0006&mi_00#7&2461c7c3&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
redlink>
redlink>ProbeStatus
Index = 1
Manufacturer = NXP
Description = LPC-LINK2 REDLINK
VID = 21BD, PID=0006
Path = \\?\hid#vid_21bd&pid_0006&mi_00#7&2461c7c3&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
IsOpen = FALSE
WireInitialized = FALSE
WireProtocol = JTAG
CoresConfigured = FALSE
PacketSize = 1024
Probe Reference Count = 0
HasSWV = FALSE
HasETM = FALSE
HasJTAG = TRUE
HasSWD = TRUE
Probe Type = REDLINK
redlink>
redlink>
redlink>
redlink>ProbeIsOpen 1
FALSE
redlink>ProbeOpenByIndex 1
Handle = 1
redlink>WireIsConnected 1
FALSE
redlink>WireJtagConnect 1
redlink>ProbeStatus
Index = 1
Manufacturer = NXP
Description = LPC-LINK2 REDLINK
VID = 21BD, PID=0006
Path = \\?\hid#vid_21bd&pid_0006&mi_00#7&2461c7c3&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
IsOpen = TRUE
WireInitialized = TRUE
WireProtocol = JTAG
CoresConfigured = FALSE
PacketSize = 1024
Probe Reference Count = 0
HasSWV = FALSE
HasETM = FALSE
HasJTAG = TRUE
HasSWD = TRUE
Probe Type = REDLINK
redlink>CoresConfigured 1
FALSE
redlink>CoreConfig 1
Number of CORES/TAPs = 1, Fully recognized: True
redlink>
redlink>CoreList 1
RedlinkAPI: Hardware interface transfer error
redlink>
redlink>
redlink>
redlink>
redlink>
redlink>ProbeStatus
Index = 1
Manufacturer = NXP
Description = LPC-LINK2 REDLINK
VID = 21BD, PID=0006
Path = \\?\hid#vid_21bd&pid_0006&mi_00#7&2461c7c3&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
IsOpen = TRUE
WireInitialized = TRUE
WireProtocol = JTAG
CoresConfigured = TRUE
PacketSize = 1024
Probe Reference Count = 0
HasSWV = FALSE
HasETM = FALSE
HasJTAG = TRUE
HasSWD = TRUE
Probe Type = REDLINK
redlink>exit
[Closed]


Regards
Pietro

Outcomes