lpcware

Failed to parse MIB file error while snmpwalk command in SNMP

Discussion created by lpcware Employee on Jun 15, 2016
Content originally posted in LPCWare by MOHAMMAD BIYABANI on Wed Jun 12 21:52:14 MST 2013
<div>
<div id="ticket_content">
<div class="markdown_content">

Hi,
I am working on ARM9 based LPC3250 controller with linux kernel version 2.6.34 in ubuntu 11.10 based host.


I have downloaded NET-SNMP-5.4.3 version package from NET-snmp web site and created SNMPD binary file with below configuration and tried to port that binary file into NMS board using NFS(NETWORK FILE SHARING).


The procedure to make binary file and porting that file into board is (that i was used)


<ol>
<li>Go to the contained file of NET-SNMP like below</li>
</ol>

root@biya:/home/biya/net-snmp-5.4.3#


<ol>
<li>Run ./configure command with below arguments</li>
</ol>

root@biya:/home/biya/net-snmp-5.4.3# ./configure --enable-mini-agent --with-cc=arm-linux-gcc --with-mib-modules=mibII --target=arm-linux- --build=i686-pc-linux-gnu --host=arm-linux- --disable-scripts --disable-embedded-perl --enable-static=yes --with-endianness=little --without-perl-modules --disable-manuals --with-rpm build_alias=i686-pc-linux-gnu host_alias=arm-linux target_alias=arm-linux --with-default-snmp-version="1" --with-sys-contact="root" --with-sys-location="unknown" --with-logfile="/var/log/snmpd.log" --with-persistent-directory="/var/net-snmp"


<ol>
<li>Perform Make operation</li>
</ol>

root@biya:/home/biya/net-snmp-5.4.4# make
root@biya:/home/biya/net-snmp-5.4.4# make install


Then BINARY file created with name "snmpd", and ported that file into board using(NFS) below procedure after kernel booting


~ # mkdir nfs
~ # mount -t nfs -o nolock 192.168.1.10:/home/biya/nfs /nfs
/nfs # ./snmpd
then it is giving below output
Entered into program


Then i have tried to use SNMPWALK from host to/from target then No response from both sides


The procedure i followed is
/nfs/net-snmp-5.7.2_bin_1/apps # ./snmpwalk -v1 -c public 192.168.1.101
/usr/local/share/snmp/mibs: No such file or directory
Timeout: No Response from 192.168.1.101
/nfs/net-snmp-5.7.2_bin_1/apps # ./snmpwalk -v1 -c public 192.168.1.41
/usr/local/share/snmp/mibs: No such file or directory
Timeout: No Response from 192.168.1.41


I was thought that it is missing MIBS so,
I have found MIBS in host path /usr/local/share/snmp/mibs After MAKE INSTALL command while generating SNMPD binary
I have created same path /usr/local/share/snmp/mibs on NMS BOARD and i copied that MIBS into created path.


Then i tried with SNMPWALK COMMAND then it is not giving any response.


The procedure that i have followed and output is shown below,


<h1 id="mkdir-nfs">mkdir nfs</h1>
<h1 id="mount-t-nfs-o-nolock-192168141homemohannfs-nfs">mount -t nfs -o nolock 192.168.1.41:/home/mohan/nfs /nfs</h1>

~ # cd usr/
/usr # mkdir local
/usr # cd local/
usr/local #mkdir share
/usr/local # cd share/
/usr/local/share # mkdir snmp
/usr/local/share # cd snmp/
/usr/local/share/snmp # mkdir mibs
usr/local/share/snmp #cd mibs/
/usr/local/share/snmp/mibs # pwd
/usr/local/share/snmp/mibs


I mounted MIBS using NFS and copied into /usr/local/share/snmp/mibs


/nfs/usr/local/share/snmp/mibs # cp -r NET-SNMP-<em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r UCD-</em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r SNMP-<em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r SNMPv2</em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r DISMAN-<em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r IANA-</em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r HOST-<em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r AGENT-</em> /usr/local/share/snmp/mibs
/nfs/usr/local/share/snmp/mibs # cp -r IP* /usr/local/share/snmp/mibs


~ # export MIBS=/usr/local/share/snmp/mibs


~ #nfs/net-snmp-5.7.2_bin_1/apps # ./snmpwalk -v1 -c public 192.168.1.101
Failed to parse MIB file /usr/local/share/snmp/mibs
Timeout: No Response from 192.168.1.101


Why it is giving Failed to parse MIB file error.
Please help me .


Thanks &amp; Regards,
MOHAMMAD BIYABANI.


</div>
</div>
</div>

Outcomes