lpcware

UART3 boot: no reply from '1830 after sending image

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Grant.Edwards on Wed Jul 24 14:39:39 MST 2013
I've been successful placing the processor into UART3 boot mode.

I send '?' and receive 'OK\r\n'.  So far, so good.

After I send the header+image, I never get any sort of response (it's supposed to reply 'OK\r\n' or 'FAILED\r\n').  The most likely thing I can think of is that I'm not constructing the header correctly, but I can't see anything wrong.  I pad the image tself out to a 512 byte boundary, and then send a header that looks like this:

da ff 0d 00 00 00 00 00 00 00 00 00 ff ff ff ff


Byte 0 (da) means AES inactive, no hash.

Byte 1 is reserved and unused hash-adjust bits.  Reserved bits are all 1's, I've tried all 1's and all 0's for unused hash-adjust bits.

Bytes 2-3 (0d 00) are the image size (in 512-byte blocks) -- 13 in this case.  I've tried both little-endian and big-endian format for this field.

Bytes 4-11 are the hash value (not used).  I've tried all 1's and all 0's.

Bytes 12-15 are reserved and must be all 1's.

Then I send the image itslef which comprises 13 blocks of 512 bytes each.

Then I expect a response of 'OK\r\n' or 'FAILED\r\n', but I get nothing.

I've concluded that the user manual description of either the hader or the UART boot protocol is wrong (no big surprise, I found dozens of errors in the manual).

Where can I find accurate information about the UART boot protocol and the binary header format?

Outcomes