lpcware

LPC183x TFGA100 JTAG/SWD not working

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by jones_hsu on Fri May 17 11:48:15 MST 2013

Hi Sir, 


  We got issue from this week which JTAG/SWD lost link with the chip,


   some condition as Below :


  1. Keil 4.5 + Jlink , and SPIFI mode.


  2. the chip is LPC1830BGA100--, and LPC1837BGA100-A


    there are 5 pcs of 10 PCB lost link after a week working.


 3, base On openplatform 1.02 , we just add some GPIO and timer control ..


   no CRP register touch , no AES touch ..


  4. when lost JLINK, the chip is working normal , SPIFI interface working.


     only JTAG lost link, and can't update .


 5. when lost Jlink, P2.7 ISP pin control is not working.


6. When lost Jlink, we try to configure boot mode from USB1 ,


    and it's working, i can install LPC USBD driver.


6. we try to replace SPI flash ( W25Q32BV) , and Jtag still not working.


   even remove SPI Flash , Jlink still not working.


7. those PCB are working normal few days , and working by un-know reason.


any suggestion for us ?


tks !


 BR,Jones 

Outcomes