lpcware

MCB1800 software reset

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by moualek_adlene on Mon Dec 22 02:08:51 MST 2014
Hi,
i can't do a software reset on a Keil MCB1800 Board with LPC1857 ARM processor. I use Keil uVision 5 and ULINK-ME as debugger. I have tried many solutions found on Keil and NXP forums without success.
Essentially, solution 1 consist on this :

*(volatile unsigned int *)0x40043100 = 0x10400000; //memmap with boot ROM address
*(volatile unsigned int *)0x40053100 =(1<<0); // Core reset

and solution 2 is this one :

NVIC_SystemReset();

Also i have disabled all IRQ before to try to reset the board.
For solution 1 nothing happen at all after reset instructions, while for solution 2 the program seems to successfuly initiate a reset but stop in the sub-procedure SetClock situated in system_LPC18xx.c and more exactly at this instruction :

LPC_CGU->XTAL_OSC_CTRL = (0 << 0) |   /* Enable oscillator-pad              */
                                                (0 << 1) |   /* Operation with crystal connected   */
                                                (0 << 2) ;   /* Low-frequency mode                 */
.
If there is no solution to make this board correctly reboot, i want to know if it is possible to produce a reset by connecting a GPIO pin configured as output to the RESET pin of the processor and then setting this pin low until reset occur. I thing this is the best solution (because this will produce real hardware reset effects) but i haven't tried it.
Thanks for any response.

Outcomes