lpcware

Problem connecting to NGX Xplorer 1830 Board

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by sarrasmith on Tue Feb 02 17:14:29 MST 2016
Hello,

I purchased this board (http://shop.ngxtechnologies.com/product_info.php?products_id=105) about a month ago with an LPC-Link2 debugger board. It all worked perfectly out of the box. Shortly after I changed to a different eval board, but am now switching the project back to this one. Now, however, I can't seem to run anything on the NGX board.

The LPC-Link2 lights up when connected to the computer, and the other board's power LED also lights up when that board is powered from a wall wart (just to avoid any potential com port confusion).

I am using LPCXpresso v7.9.2 and this project was made in the same version.

In LPCXpresso, when I do Debug As > NXP MCU Application (with all the debug configurations deleted), it asks me to choose which CMSIS-DAP emulator to use. It sees the LPC-Link2 and lets me continue. Once the project builds (with no errors), I get two popup windows saying:


Quote:
Error reported by target

Target reported errors

Reason:
02: Failed on connect

02: Failed on connect
Could not connect to core.
31: No connection to emulator device



and


Quote:
Problem Occurred

'Launching lpc1837_test1.axf' has encountered a problem.

Error in final launch sequence

Failed to execute MI command:
-target-select extended-remote | crt_emu_cm_redlink -msg-port=52199 -g -mi -2 -pLPC1837 -vendor=NXP -ResetScript=LPC18LPC43InternalFLASHBootResetscript.scp -reset= -ProbeHandle=1 -CoreIndex=0 -flash-driver=LPC18x7_43x7_2x512_BootA.cfx
Error message from debugger back end:
Remote communication error. Target disconnected.: No error.
Remote communication error. Target disconnected.: No error.



I've been looking through the forums and tried everything that seemed reasonably related. I could not find any helpful information on the pages that the "Help on this error..." button takes me to (https://www.google.com/search?q=02:%20Failed%20on%20connect&sitesearch=http://www.lpcware.com/content/faq/lpcxpresso&gws_rd=ssl)

Any thoughts?

Outcomes