lpcware

Trouble interconnecting 2 LPC1769 UARTS Through RF module

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by ewajs on Sat Oct 26 12:09:49 MST 2013
Hi,
I'm using 2 LPC1769 and trying to interconnect their UART's through a standard 434MHz RF Module.

The first attempt was to connect both UART's directly (using a wire), the program worked as expected (turning on and off a led in the receiver when the transmitter send a specific character). When linking the LPC's through a standard RF 434MHz Module and a HT12D and a HT12E on the transmitter (simple encoder and decoder) the LED stopped blinking.

We tried to interconnect them using simple GPIO's instead of the UART's and the program started working again. So we narrowed the problem down to using both the UART and the RF modules (with encoder or decoder), it must be some electrical issue of the UART either on the transmitter or the receiver (or both), but we can't figure it out.

Things we tried:
- Using a pair of resistors to lower the input voltage from the decoder (and encoder) from 5V to 3.3 V (we needn't do this when we used just the GPIO's)
- Using a JFET transistor to isolate both UART's from the enconder/decoder in case there was a current drainage issue.
-Tried 2400, 4800 and 9600 Baud Rates.

Thanks for your help.

Outcomes