lpcware

Can't receive on UART3?

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by tjoAG on Wed Jun 27 02:36:08 MST 2012
Hi All

I have some problem utilizing the UART3 of the LPC1788

If have remembered to power it on the the PCONP register.
I set the desired baudrate, stop bits etc. I have enabled FIFO and TX

I have UART0 and UART1 working fine with no problems at all.

I can see on my scope, that there is a correct TX signaling. There is also a RX signal back to the LPC1788 (Probed on the CPU pin directly so there is connection back to the RX pin)

But the RDR bit is never set in the LSR register. Even though I can see a signal on the RX pin.
I also have tried connecting the TC and RX from the U3 directly to each other (Loop back). Still, the RDR bit is never set.
I have tried disabling the FIFO, no luck
I have tried different baudrates, no luck

I have triple checked with the UART0 and UART1 configuration, register by register and the peripherals view in the KEIL uVision Debugger. Seems to be configured correctly!

Also, the TX from the UART3 works and is send with the expected baudrate and received correctly. So the UART3 must be configured correctly.

Have I missed something, either hiden or difficult to see, in the NXP LPC1788 user guide? Would not be the first time :-)

Thomas

Outcomes