lpcware

[LPC1788] ISP autoboaud issue

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by pgr on Mon Mar 16 04:39:11 MST 2015
Dear all,

I am using FlashMagic to flash an LPC1788 on a custom board.
I have already been able to correctly flash some LPC1763 using same USB to serial cable and same configuration.

With the LPC1788 I almost always get the auto baud error.  I have connected my logic analyser on both RX and TX and found everything correct, the LPC1788 answer with the "Synchronized\r\n" command. I have tried to send from the FashMagic terminal the sync character '?' and get the following answer: "“ùîãèòïîéúåä" instead of the expected "Synchronized\r\n".

Accordingly to my logic analyser the bit rate of the answer is 108108 bits/s instead of the expected 115200.
I have tried to reduce speed to 38400 and the LPC1788 answer at 37735. For 19200 the LPC1788 answer at 19323.

Does anybody have any idea why my LPC1788 answer using the wrong speed when using 115200 ? I have no external quartz and use the internal RC oscillator.

Thanks in advance

Outcomes