lpcware

Problem with programming custom hardware.

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by pdavenport on Mon Aug 04 19:12:26 MST 2014
Hi,
I have been working on a project with the lpc1769 microcontroller and have had a terrible time getting my custom hardware to program. In prototyping I have played with the mbed and the LPCxpresso develoupment boards for the lpc1769. These have worked fine, the LPCxpresso software worked as expected and I designed our custom hardware to basically be the same as the LPCxpresso target side of the board with a header for programming that is identical to the header used for programming the target side of the dev-board.
But the system refuses to recognize. I have also tried with multiple other tools. The only other thing that has had any success is using a bus pirate to do ISP over the UART. But whenever this starts working it will stop working after a short period of time. I believe that there is some sort of hardware problem in my design but I cant isolate it.
I attached a picture of the applicable page of my schematic, everything else is just peripheral stuff. I am doing development from a windows 7 pro laptop, with a working LPCxpresso development board as the programmer (by cutting the solder jumpers and connecting to my hardware). The hardware has been tested and no shorts are apparent. I am powering the board off of the programmer (LPC-Link) and only populated the components that are necessary for booting the chip (decoupling caps, main oscillator, and pull ups on the ISP enable pin and reset lines).

As I said before I am able to power up and talk to the chip through the UART auto baud ISP but after playing with that for a little bit the chip stops responding. I have tried this on a couple different units of the board and am sort of at a dead end. At no point have I been able to get SWD or JTAG to work from the LPC-Link or any other tool.

Any suggestions would be very much appreciated,
Peter

Attachments

Outcomes