lpcware

EA-LPC1788 Board - uCLinux Kernel problem

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by norbert on Mon Jun 18 14:11:58 MST 2012
Hi,

i have tried to run uClinux on the EA-LPC1788 board.

I used the documentation from emcraft.com. I build the bootloader with the SourceryCode crosscompiler.
Then I copy it on the board...that works nicely.

After that I compiled the kernel (found it in emcraft git repository : https://github.com/EmcraftSystems)

i tried the .config that can loaded with: make ea-lpc1788_defconfig

then i compiled it with a busybox binary:
make uImage (in $PATH is the mkimage)

build without problems.

After that I tried to load it on the board via tftp, first i set the env variables,

then i load the kernel : tftp uImage

Download without problems.

Then I'll try to boot the kernel:
bootm

The problem is that the board hangs up at "Starting Kernel"

Full output:

## Booting kernel from Legacy Image at 0xa0000000 ...
   Image Name:   Linux-2.6.33-arm1
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1108864 Bytes =  1.1 MB
   Load Address: a0008000
   Entry Point:  a0008001
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

than it hangs up... :/



then i tried to debug the kernel by compiling KernelHacking -> low-level Debug.

After that I got following error:

...

Starting kernel ...

UNHANDLED EXCEPTION: HARD FAULT
  R0    = 00000055  R1  = 00000020
  R2    = 00112f20  R3  = 03ffffff
  R12   = 00000024  LR  = a000894d
  PC    = a0008924  PSR = 21000200


What to do to fix this? Can someone send me his .config?

Somebody have an idea?


Kind regards,

Norbert

Outcomes