lpcware

LPC1517 doens't respond

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by BowlingNL on Tue Aug 05 07:22:28 MST 2014
I'm experiencing a problem with the ISP and SWD of the LPC1715. I can't debug or program the device, not by the SWD or ISP.

This morning it was working perfectly, but suddenly I couldn't debug the device any more, I was getting some error about RedLink server. So I tried to program the device by ISP, that also wasn't possible. So I assumed the device was broken, and I replaced it for a new one.
With the new device installed I first tested the ISP, and worked fine (I didn't program the device, only read the device ID). Then I started a debug session within LPCXpresso, at first it looked it was okay. But than the error appeared again. After that the ISP also doesn't work anymore.

I use a custom board, with the latest version of LPCXpresso en LPCopen. Can software cause the device to become unusable? The crystal is still oscillating.

Can anyone help me?


Guy

Outcomes