lpcware

lpc1227 (lpcxpresso board) not debuggable/programmable: any way to rescue it?

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by noprofit on Wed Feb 06 11:40:22 MST 2013

Hi all,

I successfully programmed/debugged my applicationon this board during the past two weeks.

Today I lost the ability to program/debug the lpc1227.

I tried using:

- the LPC-Link thourgh the LPCXpresso IDE obtaining

  02: Failed on connect
  Bad ACK returned from status - wire error.
  Emu(0): Connected. Was: None. DpID:     EDB6. Info: HID64HS12

- the Jlink through the IAR workbench 6.5 for arm obtaining:

  Unable to get CPU status after 4 retries. Retry?

- the Ulink2 through the Keil uVision IDE obtaining:

  SWD Communication failure. (kinda..do not remember exactly..sorry)

The application currenty (if the mcu is not bricked) executing is about deep sleep mode woken up by 1Hz RTC. I notice a strange LED2 activity that blink very feebly.

I also tried to
- put ISP pin to low state during reset and
- try connecting through all the methods exposed above...

...but it didn't solve my problem.


Is there any way to recover the mcu?

Thanks for the (eventual) support. ^_^

Best regards,
Francesco

Outcomes