lpcware

RTX Memory Problem - LPC1347

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by marcolotz on Tue Feb 25 06:51:14 MST 2014
Hello all,

I am having problems with memory allocation when running RTX in my LPC1347. I am using lpcxpresso 6.1
Last week I have downloaded the last RTX version from Keil's website.
I have fixed all the compilation errors and now it looks like the project is compiling fine.

In the main.c, there is a call for a function called osThreadCreate().
The problem is that it returns a threadId = 0  to all the Threads that I try to create.

I have also tried to debug this error and looks like the RTX is having problems to free memory. The OS is returning
the following error: osErrorNoMemory. In debugging one can see that all that happens in the CM_SIS.c

I have tried many solutions and couldn't find an answer for why this error is happening. I guess it may be the linker, but if that is so, how to correctly configure it?

I have exported all the projects and its dependencies. The main is in the RTOS_Blinky. The project is attached to this post.

Original Attachment has been moved to: lpc1347_0.zip

Outcomes