lpcware

LPC 4088 SPIFI Fails to unlock

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Blackclaws on Wed Jul 29 09:56:15 MST 2015
I've been playing around with the SPIFI flash on the LPC4088 EA quickstart board.

I'm using the spifiLib from LPCOpen

It all worked fine until just now when my program operations started to fail with "Device Locked"

I then tried multiple things:

Power cycling the device,
Running spifiDevUnlockDevice from spifilib which returns with no error.
Running spifiDevEraseAll which returns again with Device Locked.

None of these unlock the device.

So I'm wondering whether this means that for some reason my Spifi flash suddenly died? I can still read it without error. Just erasing and writing is no longer possible. However the number of write cycles are probably at around 100. It would be very strange if the flash was dead or something like that.

Is there any hard way to unlock the SPIFI flash? Could this be an error in spifiLib? Is there any other way to find out what really is going on with my flash?

Outcomes