AnsweredAssumed Answered

error: LS1020A: Core not responding while bringing up custom board .

Question asked by Dhruvalkumar Patel on Jun 14, 2016
Latest reply on Jun 16, 2016 by Yiping Wang


Hi All I have custom board with LS1020A . I am trying to bring it up for the first time . I am using code warrier tap (USB) . I got following error (logged in code warrier server )

 

 

check_min_version(serverh=0,*version)

  api version: 00000004 00000006

get_connection_count(serverh=0,cc_index=0,*count)

  count:1

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

available_connections(serverh=0,*count,*cc)

  connections: {0,73,0xa9fe0d39}

cc_version(serverh=0,cc_index=0,index=0,*version)

get_config_chain(serverh=0,cc=0)

config_server(config_reg=0,config_data=0x00002710)

config_chain(serverh=0,cc=0,count=3,*devlist,*generic)

  devlist: ls1020a,dap,sap2

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=0,size=4,*reg)

  reg: 0000009E

config_template(coreh.{serverh=0,cc_index=0,chain_pos=0},config_reg=4096,config_data=0x00000001)

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4102,size=4,*reg)

  reg: 40025A00

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4103,size=4,*reg)

  reg: 21046000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4104,size=4,*reg)

  reg: 00000000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4105,size=4,*reg)

  reg: 00000000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4106,size=4,*reg)

  reg: 00000000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4107,size=4,*reg)

  reg: 00038000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4108,size=4,*reg)

  reg: 20024800

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4109,size=4,*reg)

  reg: 24049340

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4110,size=4,*reg)

  reg: 00000000

write_register(coreh.{serverh=0,cc_index=0,chain_pos=0},index=4111,size=4,*reg)

  reg: 00000000

reset_to_debug(serverh=0,cc=0)

  ERROR(39): Subcore error encountered during multicore operation

parse_error_ext(coreh.{serverh=0,cc_index=0,chain_pos=0}, 39)

  error: LS1020A: Core not responding

reset_to_debug(serverh=0,cc=0)

  ERROR(39): Subcore error encountered during multicore operation

parse_error_ext(coreh.{serverh=0,cc_index=0,chain_pos=0}, 39)

  error: LS1020A: Core not responding

reset_to_debug(serverh=0,cc=0)

  ERROR(39): Subcore error encountered during multicore operation

parse_error_ext(coreh.{serverh=0,cc_index=0,chain_pos=0}, 39)

  error: LS1020A: Core not responding

 

Dose any one have any idea about it. I tried to use hard coded RCW option . Am I missing any jtag chain config ??

Outcomes