AnsweredAssumed Answered

HDMI hotplug not working

Question asked by karan bhagoji on Jun 2, 2016
Latest reply on Jun 3, 2016 by igorpadykov

Hello All

 

Currently I am using a HDMI for mirror display on an sabresd board with

Android L. The system is able to mirror the displays on android bootup.

 

Here we observe a performance issues when the HDMI is enabled.

This issue is seen with/without the HDMI display connected.

The performance issue is seen as slowly response on icon launching and

other user operations. Also the notification for the HDMI connected is not raised.

 

During debugging this issue, we found that the at the driver level the

hotplug events are not received from the HDMI connector(HDMI_HPD pin), Since the

hot plug events are not received by the driver the system is unable to

power down/ deinit / disconnect the HDMI display device , thus the android system is

continuously trying to mirror the display. Further analyzing the driver

we found that the interrupt configuration is correct.

 

We also diverged into enabling the hdcp for the driver, but that too is

unable to get the interrupt from the HDMI connector.

 

The configuration in the device tree is as folows

&hdmi_audio {

        status = "okay";

};

&hdmi_cec {

        pinctrl-names = "default";

        pinctrl-0 = <&pinctrl_hdmi_cec_2>;

        status = "okay";

};

&hdmi_core {

        ipu_id = <0>;

        disp_id = <0>;

        status = "okay";

};

&hdmi_video {

        fsl,phy_reg_vlev = <0x0294>;

        fsl,phy_reg_cksymtx = <0x800d>;

        status = "okay"

};

&i2c2 {

        clock-frequency = <100000>;

        pinctrl-names = "default";

        pinctrl-0 = <&pinctrl_i2c2_1>;

        status = "okay";

#if 1

        hdmi: edid@50 {

                compatible = "fsl,imx6-hdmi-i2c";

                reg = <0x50>;

        };

#endif

};

 

Regards,

Karan

Outcomes