AnsweredAssumed Answered

CAAM hangs in SHA-1

Question asked by AlexeyT on May 26, 2016
Latest reply on Jan 9, 2017 by Michael Männel

Hello All,

 

I am trying to implement hardware SHA-1 calculation support for my project.

My platform in Windows Embedded Compact 7

We don't need anything else, just a hardware calculation of SHA-1 which will only be done once.

I got necessary manuals etc. and started my implementation.

Implemented job ring support and tried constructing my job.

 

Basically, job ring interface works for me ok, I managed to run job which just loads 64 bytes of data into class 2 FIFO and it executed just fine.

This would mean that CAAM is functioning ok.

 

Problem starts when I try adding SHA-1 algorithm command: it just hangs in there and job execution hangs.

My job (currently) is very simple:

- header

- fifo load data into class2 message, final

- SHA-1 algorithm, no key, init/fin, class 2

 

What would cause SHA algorithm to hang? Did I miss something in initialization?

I tried just to call SHA1 init without of any data feed to FIFO; it still hangs...

(AFAIK it supposed to initialize data structures and then leave)

 

Our system runs HAB in bootloader and most of the CAAM initialization (presumably) happens there.

 

I almost run out of ideas where to look for possible problem(s).

Any help would really appreciated.

 

Alexey

 

UPD Question

Do I need to prime CAAM SHA1 with initial data?

My code does not do it. Could it cause my issues?

Outcomes