AnsweredAssumed Answered

Qt Cross Compile for GENIVI 7

Question asked by Nirmal T M on May 5, 2016
Latest reply on May 10, 2016 by Bio_TICFSL

Hi,

I am cross compiling the Qt 5.5 for my iMX6 Sabree Ai board with GENIVI 7.0.3 (intrepid-image) File System. Also I have installed the EGLFS Libraries in the GENIVI file system. while configuring the Qt for cross compile I received the following error.

his is the Qt Open Source Edition.

You are licensed to use this software under the terms of
the Lesser GNU General Public License (LGPL) versions 2.1.
You are also licensed to use this software under the terms of
the GNU Lesser General Public License (LGPL) versions 3.

You have already accepted the terms of the Open Source license.

<srcbase> = /media/acs/f64c24ce-b50c-4395-bb84-429476e2905a/static-qt-new/qt5/qtbase
<outbase> = /media/acs/f64c24ce-b50c-4395-bb84-429476e2905a/static-qt-new/qt5/qtbase
Creating qmake...
..Done.
Running configuration tests...
Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
Note: PKG_CONFIG_SYSROOT_DIR automatically set to /home/acs/Downloads/L3.14.52_1.1.0-ga_images_MX6QDLSOLO/fsl-image-gui-fb-imx6qdlsolo

Could not determine the target architecture!
Turn on verbose messaging (-v) to see the final report.
The OpenGL ES 2.0 functionality test failed!
Use of pkg-config is not enabled, maybe you want to pass -force-pkg-config?
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in
/media/acs/f64c24ce-b50c-4395-bb84-429476e2905a/static-qt-new/qt5/qtbase/mkspecs/devices/linux-imx6-g++.

I have used the gcc-linaro-5.2-2015.11-1-x86_64_arm-linux-gnueabihf-g++ as a cross compile tool chain

Is it possible to clear this error.
I need to build the Qt with EGL support,
Kindly help

Outcomes