AnsweredAssumed Answered

I.MX6Q Sabre Auto HDMI audio not working

Question asked by Deepika Teriar on May 5, 2016
Latest reply on Jan 25, 2017 by vinod kumar

Hi

 

I am working on SabreAuto IMX6Q running Android Marshmallows(6.0.1). I am able to see HDMI video but my HDMI audio is not working. My bootargs are:

 

setenv bootargs console=ttymxc3,115200 androidboot.console=ttymxc3 consoleblank=0 vmalloc=320M init=/init video=mxcfb0:dev=hdmi,1920x1080M@60,bpp=32 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off androidboot.hardware=freescale cma=384M.

 

In the kernel logs I am getting the following:

 

imx-audio-hdmi sound-hdmi.22: hdmi-hifi <-> hdmi_audio.3 mapping ok

 

ALSA device list:

  #0: cs42888-audio

  #1: imx-spdif

  #2: imx-hdmi-soc

 

I am unplay to listen to audio from HDMI.

In  android console I am getting the following error :

root@sabreauto_6q:/ # logcat | grep audio_hw_primary

01-01 00:16:29.668   221   521 W audio_hw_primary: ret -1, pcm write 768 error cannot prepare channel: Device or resource busy

01-01 00:16:29.672   221   521 W audio_hw_primary: ret -1, pcm write 768 error cannot prepare channel: Device or resource busy

01-01 00:16:29.676   221   521 W audio_hw_primary: ret -1, pcm write 768 error cannot prepare channel: Device or resource busy

01-01 00:16:29.677   221   521 W audio_hw_primary: pcm_write_wrapper continues failed for pcm 1, standby

01-01 00:16:29.677   221   521 W audio_hw_primary: do_out_standby... -1241192256

01-01 00:16:29.682   221   521 I audio_hw_primary: start_output_stream... -1241192256, device 1024

01-01 00:16:29.685   221   521 W audio_hw_primary: card 2, port 0 device 0x400

01-01 00:16:29.685   221   521 W audio_hw_primary: rate 48000, channel 2 period_size 0x300

01-01 00:16:39.757   221   521 W audio_hw_primary: ret -1, pcm write 768 error cannot prepare channel: Device or resource busy

01-01 00:16:39.761   221   521 W audio_hw_primary: ret -1, pcm write 768 error cannot prepare channel: Device or resource busy

01-01 00:16:39.766   221   522 W audio_hw_primary: out_set_parameters routing=1024, ret 0, out -1241192256

 

I am not able to understand why are we getting device or resource busy error? Do we need to enable something else for HDMI audio

 

Thanks and regards

Deepika Teriar

 

 

 

Outcomes