AnsweredAssumed Answered

How to configure LPUART clock properly on KL17

Question asked by ken.sloat on May 2, 2016
Latest reply on May 2, 2016 by Alice_Yang


I am wondering how to properly configure the LPUART clock frequency on a KL17. I see in the driver where I can set the clock source:

   *  00: Clock Disabled

     *  01: IRC48M

     *  10: OSCERCLK

     *  11: MCGIRCCLK

 

Currently we have IRC48M, but since this seems to be an internal clock, we believe it may be inaccurate because we're seeing occasional junk characters on UART. I could change it to OSCERCLK, however with a 32K oscillator we won't be able to properly hit 115200 baud.

 

Btw this is using KSDK 2.0

Outcomes