AnsweredAssumed Answered

Android M6.0.1-1.0.0-GA patch error!

Question asked by Peter Tseng on Apr 27, 2016
Latest reply on Jun 22, 2016 by Carol Desjardins

Hi i.MX Community,

 

I could not patch android_M6.0.1_1.0.0_core_source.tar.gz

 

$ source /opt/android_M6.0.1_1.0.0_core_source/code/M6.0.1_1.0.0/and_patch.sh

$ help

Invoke ". and_patch.sh" from your shell to add following functions to your environment:

-- c_gotop: Changes directory to the top of the tree

-- c_patch: Recover working tree to base version and then applying FSL android patch

 

$ c_patch /opt/android_M6.0.1_1.0.0_core_source/code/M6.0.1_1.0.0/ imx_M6.0.1_1.0.0

 

Parsing basefile /opt/android_M6.0.1_1.0.0_core_source/code/M6.0.1_1.0.0/baseversion...

Check work tree and patch dir based on /opt/android_M6.0.1_1.0.0_core_source/code/M6.0.1_1.0.0/baseversion...

Checking NEW project - device/fsl ...

Checking NEW project - device/fsl-proprietary ...

Checking NEW project - external/fsl_vpu_omx ...

Checking NEW project - hardware/imx ...

Checking NEW project - hardware/realtek ...

Checking NEW project - packages/apps/fsl_imx_demo ...

Checking NEW project - external/linux-lib ...

Checking NEW project - external/linux-test ...

Checking NEW project - external/linux-firmware-imx ...

Checking NEW project - external/ntfs-3g ...

Checking NEW project - external/powerdebug ...

Checking NEW project - external/mtd-utils ...

Checking NEW project - external/busybox ...

Checking CHANGE project - frameworks/base ...

fatal: Not a git repository (or any of the parent directories): .git

Error! Base version commit 4d70bd7a928903b35c92619437c70bc382587b71 doesn't exist in git /home/workspace/myandroid/frameworks/base. Stop

 

Hope for your help!

 

Regards,

Outcomes