AnsweredAssumed Answered

openocd error

Question asked by Martin Fiset on Apr 22, 2016
Latest reply on Apr 24, 2016 by ZhangJennie

Board:     FRDM-K22F rev A1

IDE:     KDS v3.2.0

Firnware version:     0203

                                   And I upgraded to 0221 a few minutes ago  (I upgraded to 0221_k20dx128_k22f_0x8000.bin)

SDK:     v2.0 for FRDM-K22F

 

Two weeks ago I was successfull in debugging the "Hello World" example on the FRDM-K22F using OpenOCD debugging.

Today I receive errors when trying to debbug the "Hello World" example.

 

Here is what OpenOCD gives:

For bug reports, read   http://openocd.sourceforge.net/doc/doxygen/bugs.html

Info : only one transport option; autoselect 'cmsis-dap'

Error: unable to open CMSIS-DAP device

Error: unable to init CMSIS-DAP driver

Error: Error selecting 'cmsis-dap' as transport

Runtime Error: C:/Freescale/KDS_v3/openocd/bin/..//scripts/kinetis.cfg:3:

in procedure 'script'

at file "embedded:startup.tcl", line 58

in procedure 'interface' called at file "C:/Freescale/KDS_v3/openocd/bin/..//scripts/kinetis.cfg", line 3

 

And here is the error I receive from the debugger in Eclipse:

I did observe this with the original firmware version 203. Then I upgraded to version 221, but still the error is the same.

I made sure I had the "-f kinetis.cfg" in the debugger config options. Still the same error.

 

I tried running the openocd command line executable. Here is what happended:

It seems the device is secured.

But the only thing I did with the board was debugging the "Hello World" example two weeks ago, and then today I am ready to start development, and I am unable to run the "Hello World" example.

 

Any hint?

 

Thanks

Outcomes