AnsweredAssumed Answered

Unable to connect to MKE04Z8 with USBDM JS16-SWD

Question asked by anewsee on Apr 22, 2016


Hi,

 

I have spent several hours with debugging this case without any success. I would ask for your help!

 

We made a hardware with an MKE04Z8VTG4 and we have build our own JS16-SWD programmer.

Unfortunatelly is is not possible to access to the MCU via SWD. Clicking on the Detect Chip button prompts an error dialog with the message: "Failed to probe target Reason: BDM has no connection to target"

 

We have tried to Mass Erease the MCU with clicking the Mass Erase Now button, but that did not solve the problem.

We have tried to connect to our hardware via a FRDM-KL46Z board using USBDM but the result was exactly the same.

We have captured some scope shot about the communication. The obvious SWD protocol documentation was not found on the internet but it seems that the MCU does not reply to any SWD request.

 

I attached the USBDM screenshots and the scope shot.

 

We do not have any idea how to move forward.

Have you seen similar problem?

Could you give us some advice about advanced debugging?

 

Thanks.

Best Regards,

ANewsEE

Original Attachment has been moved to: scope.csv.zip

Attachments

Outcomes