AnsweredAssumed Answered

True-Time Simulator and Real-Time Debugger breakpoint troubles

Question asked by Michael Hockstein on Feb 26, 2008
Latest reply on Feb 29, 2008 by CrasyCat
Hey,
 
I'm having a little difficulty using True-Time Simulator and Real-Time Debugger.  I make my program and there are no errors.  I click debug and True-Time Simulator starts up.  Place a break point in at a certain function so that when it gets called the program will stop and I can check a few things out.  I run the program and then I call the function.  The program runs without stopping. It goes right through the break point like it doesn't see it.  Strangely I did this very same thing on Friday and it worked.
 
Second note that confuses me.  I place a breakpoint in main before anything really gets going in the program.  Once I run it the debugger stops the program at the breakpoint.  As soon as I hit "step over" the program stops and it tells me "no source reference found."  I'm not sure why that is or how to fix this problem.
 
Can anyone explain these problems and possibly why they are happening and how I can maybe make my breakpoints work again?


Message Edited by mikehockstein on 2008-02-26 09:24 PM

Outcomes