AnsweredAssumed Answered

MSD and binary file are not working together (utasker bootloader)

Question asked by Miguel Torres on Apr 22, 2016
Latest reply on Apr 23, 2016 by Mark Butcher

Hi everyone!

 

I have problems with the MSD. First, I load the binary file I found in this page: uTaskerSerialBoot_TWR-K53N512_KBOOT_HID_UART_MSD_SDHC.bin, I can see the MSD window. When I load the binary file (my little application) the msd show me the size of the binary file loaded. At then, the window of the MSD disappear and the blinking LED of the bootloader turn OFF. I tried to start my program but it is not working, after that, I pressed the reset button and the SW2 switch, again the MSD appear and I can see the binary file I loaded.

 

My program it is a blinking LED in the E2, instead of E1 (used for uTasker).

 

I changed the .lcf file with the specifications of the manual, I tried to use the uTaskerConvert.exe, uTaskerCombine.exe, I tried to changed the extension from file.hex (generated from CW) to file.bin.

 

I suppose the problem it is with the program I´m trying to load. There are certain thing that I still don´t understand.

The questions are:

 

How I can include the standard reset vector in my program?

my program is working at 50Mhz. it is this compatible with the uTasker?

do I need to reset the state of the ports in the begin of my program?

somebody know why it is not working?

 

I attached the pics for better understanding.

 

Thanks and regards!

 

 

Attachments

Outcomes