AnsweredAssumed Answered

No Output in U-Boot Console

Question asked by tschutte on Apr 19, 2016
Latest reply on Apr 21, 2016 by tschutte

I am attempting to secure boot using the p4080 (v2) and U-boot.

when I try to use both the RCW with SB_EN enabled and U-Boot with #define CONFIG_SECBOOT, rebooting the serial console results in the system immediately locking up (I get no output back whatsoever).  I have tried waiting for a while thinking that it needs some time to make it to the prompt, but it never happens.  To be clear, if I build U-Boot with just CONFIG_SECBOOT (no other modifications) and use the RCW with SB_EN bit set, then the system locks up entirely.

 

status register of sec mon block (location CCSRBAR +0x314014). : Shows as everything is OK

SCRATCHRW2 register : Shows as everything is OK

Sec Mon in Trusted State (0xd) : So everything is OK

Check the entry point field in the ESBC header : Appears to be okay. I have tried moving it around to different suggested locations and that doesn't seem to get anywhere.

 

 

------------

NOTE : If you comment on this question, please don't mark it as 'assumed answered' It feels like the response are slow enough, and that only slows them more..

Outcomes