Oscar Sanz

_asm_startmeup: problem on MCF52233 with ___SP_INIT addres...

Discussion created by Oscar Sanz on Feb 26, 2008
Latest reply on Feb 27, 2008 by Oscar Sanz
Hello;
 
I have a problem with ___SP_INIT addres when is set inside _asm_startmeup: function...
 
I don't know why, but after my last complilation the software has not worked anymore.
After many times trying to start the debugger on the codewarrior, i had the same exception error about vector address.
 
Then in order to see where the problem can be, i have compiled and run another program using the codewarrior debuger without problems.
 
After this, i have searched for the diffrences between both codes, the new one that is not working, and the old one that has worked perfectly....
 
Finaly i have found the difference:
-On the old code, the ___SP_INIT addres is filled with 0x20008000 on the _asm_startmeup:, ->OK THIS IS WORKING
 
-On the new code, the ___SP_INIT addres is filled with 0x20008EE0 and application crashes when arrives to 'SYSTEM_SysInit' function.
 
I have manually set the ___SP_INIT value to 0x20008000 on this new code and HAS WORKED!!!!!
 
MY QUESTION IS:
Where is the ___SP_INIT value configured on my code????
 
 
 

Outcomes