AnsweredAssumed Answered

[Processor Expert] This interrupt is required/Unassigned peripheral

Question asked by Lucas Magasweran on Apr 18, 2016
Latest reply on Sep 19, 2016 by Alberto Lubeiro

After changing the processor component from a K26 MK26FN2M0CAC18 to MK26FN2M0VMI18, which has the same flash, ram, and number of I/Os, Processor Expert had a few errors. I fixed most of them by specifying the referenced component, but in the `fsl_gpio` component I cannot find a solution to the "PORTC Interrupt" "missing" error.

 

I tried removing all the components that use PORTC and the GPIO pins on that port. I also tried disabling and re-enabling "Auto initialization" for this component.

 

Is there a way to fix it? Or is there a recommend process for changing the processor in a project to avoid these types of errors?

 

The problems are:

DescriptionResourcePathLocationType
This interrupt is required (Interrupt)project_namegpio1/InterruptProcessor Expert Problem
Unassigned peripheral (Device)project_namegpio1/DeviceProcessor Expert Problem

 

Selection_014.png

Outcomes