AnsweredAssumed Answered

KSDK 1.2 I2C driver debugging issue

Question asked by Rini Patel on Apr 14, 2016
Latest reply on Apr 24, 2016 by Rini Patel

Hello,

I'm running the I2C driver example located at  Freescale\KSDK_1.2.0\examples\<board_name>\driver_examples\i2c\i2c_blocking\

 

In my setup, TWR-KL43Z board is acting as master and FRDM-KL27 board as slave. (pin connections as per the KSDK Demo User's Guide).

 

Now in master side code, I've bypassed the i2c_driver APIs and instead am directly using the i2c_hal platform library functions. fsl_os_abstraction layer is not used at all.

 

 

There is a strange issue I'm facing with this approach. While debugging step wise(KSDK 1.2 with OpenSDA debugger), slave board is receiving data alright and transmits back the character received. But when I run the code as a whole, every time transmission seems to fail.

 

 

I've tried using different baud rates and inserting "nop"s where OSA_TimeDelay was in original demo. But facing the same issue. What could be the cause??

 

Thanks

Rini

Outcomes