AnsweredAssumed Answered

Problem updating bootloader for FRDM-KE06Z

Question asked by Sean Beatty on Apr 7, 2016
Latest reply on Apr 12, 2016 by Sean Beatty

I purchased a new FRDM-KE06Z board and attempted to update the bootloader. Before updating, SDA_INFO.html showed:

     MicroBoot Kernal Version: 1.05

     Bootloader Version is: 1.10

     Application Version is: 1.14

The Led blinked at a 1 Hz rate.

 

Then I tried to update the bootloader according to the P&E instructions - put the Freedom board into bootloader mode by holding down the reset button and powering up, verify the volume is labeled "BOOTLOADER", and dragging the BOOTUPDATEAPP_Pemicro_v111.SDA file to the drive. Then unplug the USB cable, plug it back in, and wait while it programs ....

 

After a few seconds, the LED starts flashing rapidly 7 or 8 times, then off for a second or two, then flashing rapidly ... repeating this pattern. SDA_INFO now shows:

Board Name is: FRDM-KE06Z
MicroBoot Kernel Version is: 1.05
Bootloader Version is: 1.10
Application Version is: 0.00
DUID is: 30133938-8F0281E2-3762D80E-B76DE678
EUID is: 2691A239-2068876C-1861FA19-957668D6
TUID is: 74823938-8063C6C9-3736F906-92389865
TOA is: 86B6E505-CA5272BA-230F3A9F-D5E34335
TOA2 is: 86B6E505-79398CC7-CE85F4A6-80964A1D
SUID is: 86B6E505-4D5A8397-37239806-8003EC65

 

It appears that the reprogramming failed. I can no longer power up the board normally into the FRDM-KE06 volume like previously - it always goes into the BOOTLOADER volume.

 

I tried this on three different boards. For the last attempt, I also disabled the virus scanner and firewall, and performed the copy using the Command Prompt (DOS) window, as suggested by some. I got the same results.

 

What happened? How do I recover?

 

Thanks for your help!

 

Outcomes