AnsweredAssumed Answered

T2080 QDS board and SFP+ modules

Question asked by Bill Paul on Mar 21, 2016
Latest reply on Mar 25, 2016 by Bill Paul

The T2080 QDS system has 6 externally available DPAA-based ethernet ports: two 10/100/1000Mbps RGMII ports (GETH1, GETH2) and four XFI 10Gbps ports (SFP1, SFP2, SFP3, SFP4). The two 10/100/1000Mbps ports have standard RJ-45 jacks and  the four 10Gbps ports are terminated in four SFP+ cages.

 

According to the documentation, it should be possible to use either direct attach SFP+ cables or SFP+ optical modules. I'm attempting to implement support in VxWorks for the 10GbE ports and I've been able to get them to work using direct attach cables, but when trying a 10GBase-SR fiber module, I'm unable to establish a link.

 

In addition to the T2080 QDS board, I have an Intel Corei5 system with a x8 PCIe slot and an Intel 82599 NIC. This NIC has two Intel-branded 10GBase-SR modules. If I connect a multimode fiber patch cable between these two ports, I get a link between both of them, so I know the modules and my fiber patch cable are good.

 

If I remove one of the fiber modules and fit it into one of the SFP+ cages on the T2080 QDS and run the fiber patch from that module to the remaining module in the 82599 NIC, I can't get a link. The LED on the NIC never lights up, and the PCS status registers on the T2080 show link down. If I remove the 10GBase-SR modules and use a direct attach cable instead, I can get a link between the 82599 NIC and the T2080 QDS and exchange traffic. The LED on the 82599 NIC lights up and the PCS status registers show that the link is up. I don't think there's anything special about the Intel optical modules that would prevent them from working in another SFP+ cage, and I have used them in another device before.

 

As a test I tried using the same 10GBase-SR module with a fiber loopback adapter but the PCS status registers on the T2080 still showed no link.

 

Also, although I'm not running Linux on the board, I am booting VxWorks with U-Boot, and U-Boot exhibits the same behavior as VWorks (I can get a link on the 10G ports with a DA cable, but not with the fiber module.)

 

I couldn't find anything in the documentation that suggests that there's anything special that has to be done to use a 10GBase-SR fiber module compared to a direct attach cable. My suspicion is that I may need to use a different optical module, but as they cost about $200 each I'm hoping to get a little more information before I spend the money.

 

My question is: has anyone else tried to use the 10GbE ports on the T2080 QDS reference board using fiber SFP+ modules? If so, did it require any special finessing or did it just work out of the box with Linux? Did you have to use a particular 10GBase-SR module?

Outcomes