AnsweredAssumed Answered

Getting permission denied error while build bootloader

Question asked by Bhavesh Patel on Mar 10, 2016

Hi,

I am using iMX287 board with Linux-2.6.35.3 Kernel. I am trying to build Bootloader imx-bootlets-src-2.6.35.3-1.1.0

In Make file it is failing while executing elftosb -z -c ./linux.bd -o i$(ARCH)_linux.sb where ARCH is defined as imx28

 

Following is snapshot of build. (command is make BOARD=iMX28_EVK)

make[1]: Leaving directory `/home/bhavesh/LinuxEmb/Bootloader/imx-bootlets-src-2.6.35.3-1.1.0/power_prep'

generating linux kernel boot stream image

by using the rootfs/boot/zImage

sed -i 's,[^ *]zImage.*;,\tzImage="zImage";,' linux.bd

sed -i 's,[^ *]zImage.*;,\tzImage="zImage";,' linux_ivt.bd

elftosb -z -c ./linux.bd -o imx28_linux.sb

make: execvp: elftosb: Permission denied

make: *** [gen_bootstream] Error 127

 

I tried with chmod 77 -R * and sudo chown -R bhavesh:bhavesh ./ to whole directory 'LinuxEmb' where everything is located. But still getting same issue.

if I run sudo make for Bootloader than it is giving error for Assembly compiling as below:

 

core/entry.S: Assembler messages:

core/entry.S:26: Error: unknown pseudo-op: `.code'

core/entry.S:31: Error: no such instruction: `stmdb sp!,{r4-r12,lr}'

core/entry.S:34: Error: no such instruction: `ldr r4,entry_count'

core/entry.S:35: Error: expecting operand after ','; got nothing

core/entry.S:36: Error: no such instruction: `bne start_kernel'

core/entry.S:42: Error: no such instruction: `bl try_to_resume'

core/entry.S:49: Error: too many memory references for `add'

core/entry.S:50: Error: too many memory references for `str'

core/entry.S:53: Error: no such instruction: `ldmia sp!,{r4-r12,lr}'

.....

 

Can anybody help me to solve this? Make file for Bootloader is attached for reference

If required I can also go for higher version of Kernel.

 

Thanks,

Bhavesh

Original Attachment has been moved to: Makefile.zip

Outcomes