AnsweredAssumed Answered

KVM on T1040RDB

Question asked by Piddy Piddy on Mar 9, 2016

Hello,

 

I am trying to run qemu/kvm on a T1040RDB (ppc, 64bit) board using Yocto and bitbake. According to documentation, KVM is disabled in the kernel build.

Although when i browse through the .bb and bbappend files i find this, in meta-virtualization/recipes-kernel/linux/linux-yocto_3.14.bbappend.

 

KERNEL_FEATURES_append = " features/kvm/qemu-kvm-enable.scc"

module_autoload_kvm = "kvm"

module_autoload_kvm-amd = "kvm-amd"

module_autoload_kvm-intel = "kvm-intel"

Doesn't this enable KVM in the kernel??

 

However, i tried to bitbake qorliq-linux and fsl-image-virt and load them onto my board, and tried --enable-kvm from qemu-system, but it tells me the KVM is not found?

 

I tried using bitbake -c menuconfig linux-qoriq to alter the kernel-build settings too but this command just finishes without ever showing me a menu.

 

What are the appropriate steps to build a kernel for T1040RDB (64bit) that allows KVM guests?

Thanks already

 

edit: i attached a file with output from T1040RDB boot

Original Attachment has been moved to: output.txt.zip

Outcomes