AnsweredAssumed Answered

Unable to flash erase mpc5567

Question asked by Rob Mellor on Mar 7, 2016
Latest reply on Mar 8, 2016 by Rob Mellor


My MPC5567EVB has stopped responding to

flash erase

I am using the PEEDI jtag programmer over telnet,

when I type in

flash erase

I am greeted with

-- error: timeout while waiting for response from the agent

-- error: timeout while erasing sector at address 0x10000000

 

at first I thought that this address was WAY off so sent it

flash erase 0x00000000 0x00200000

and got the same error.

 

The only thing that changed between working and not working was I linked pins 179 and 180 which are AF15 and AE15.

I was lead to believe these are either eTPU_A0, eTPU_A1 or eMIOS0, eMIOS1.

 

either way I would not expect that linking these would cause any impact on the programming of flash.

I have since removed all linkages and tried resetting, but I just cannot get it to flash erase.  I can read all the flash out, and have.. but Im unable to flash..

 

Have I somehow fried the EVB ability to write to flash?

Outcomes