AnsweredAssumed Answered

KL03Z interrupt

Question asked by Steven Garfinkel on Mar 6, 2016
Latest reply on Mar 22, 2016 by Steven Garfinkel

I am sure this is totally due to my inexperience but here goes.

I am using a KL03Z 8k processor in an embedded application and I cannot get the LPTMR0 interrupt (the first I am trying) to work properly.Using KDS 1.2, bare copper, interfacing to the board using a FRDM-KL03Z dev board.

Here are some code bits.  Here is the basic interrupt enable.  Lines 143 and 144 execute but when 145 executes

the processor goes off into unknown territory.  When I suspend operation the condition is always:

 

When I click on NVIC_Enable I see:

the setup for the LPTMR is for regular interrupts so I can check some inputs.  My interrupt routine is:

but the interrupt routine is not being executed.

If I comment out the NVIC_Enable the program executes, but off course no interrupts occur.

The warning is for a break point which I cannot seem to clear.  I have tried it using both interrupt number 28 and LPTMR0_IRQn and they both do the same thing.

It seems to me that the interrupt routine is not being identified properly so that upon interrupt things fall apart.

Any assistance would be helpful.

 

Also, when using the 8k processor in this configuration KDS reports that the wrong processor has been selected, even though the 8k is properly selected.  Perhaps this is due to working through the FRDM board which has a 32k part on it.

 

I previously tried some dev using processor expert but it appears PE cannot be used on 8k devices.

 

Also, I found to get the FRDM board to work properly I needed to remove an additional resistor to separate the dev interface from the processor on the FRDM board.

 

Thanks again.

Outcomes